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Understanding and Resolving the Red LightUpdated a day ago

If your Viking Gen1 Chiller is displaying a red light, this means the unit has entered protection mode due to low water flow. The red light is a built-in safety feature that shuts the chiller off to prevent damage.

Common Causes:

  1. Dirty Water Filter (on the back of the chiller)

  2. Dirty Inline Hose Strainer

  3. Air Trapped in the System

Before proceeding with deeper troubleshooting, please ensure:

  • The filter has been replaced.

  • The inline hose strainer has been cleaned.

Troubleshooting Steps:

1. Extend Hoses Properly
Ensure the unit is positioned so there are no loops or upward tilts in the hoses from the tub or chiller. The hoses should be concave. After priming the unit and successfully running it, you can return it to your preferred setup.

After the unit is successfully primed and running, you may return the chiller to your preferred setup.

2. Power Cycle the Unit
To reset and help purge any trapped air from the system:

  • Press and hold the green power button for 5 seconds

  • Release for 5 seconds

  • Repeat this process 5 times total

This helps the chiller attempt to restart and clear any remaining air that might be blocking the flow.

If you are still experiencing issues after going through these troubleshooting steps, please send a video to our customer service team at [email protected] for further review and assistance.

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